给 frida 做了个图形界面,动态分析 iOS 应用


#42

已知 bug,刷新页面即可


#43

好的 很不错的工具


#44

frida更新到11.0.0 ,cydia源里的版本也是11.npm下载的好像低版本,最后网页那显示网络错误,版本不符合,为npm指定frida最新版本,但是编译不过去,提示少头文件。。。。


#45

sudo pip install --upgrade frida


#46

frida 11 和 frida 10 不兼容,只在开发分支里升级了。

npm 少头文件的问题,你可以把整个 frida 项目 clone 下来自己编译,但其实有编译好的二进制包,需要挂代理。


#47

太厉害了吧。。。感觉我两年白干了


#48

請問一下 我的 frida 更新不了
Requirement already up-to-date: frida in /Library/Python/2.7/site-packages (12.0.5)
requests 2.18.4 has requirement idna<2.7,>=2.5, but you’ll have idna 2.7 which is incompatible.
clarifai 2.0.20 has requirement future==0.15.2, but you’ll have future 0.16.0 which is incompatible.
clarifai 2.0.20 has requirement jsonschema==2.5.1, but you’ll have jsonschema 2.6.0 which is incompatible.
clarifai 2.0.20 has requirement requests==2.13.0, but you’ll have requests 2.18.4 which is incompatible.

我暫時操作python 都是使用 開虛擬環境來操作 但 passionfruit 貌似不支持?
請問我該怎麼操作呢?


#49

passionfruit 是完全 node.js 实现的,与 Python 没有关系


#50

InternalServerError: Unable to communicate with remote frida-server; please ensure that major versions match and that the remote Frida has the feature you are trying to use
at Object.throw (/usr/local/lib/node_modules/passionfruit/node_modules/koa/lib/context.js:96:11)
at app.use.use.use (/usr/local/lib/node_modules/passionfruit/app.js:78:18)
at

運行後 打開網頁 選擇設備 出現這樣的錯誤?


#51

设备上的 frida 和 passionfruit 的 frida 版本不匹配


#52

大佬有没有让passionfruit兼容设备上最新版本frida 12.0.5 的计划


#53

passionfruit 的 frida 版本 可以更新?
因為我設備上的是 frida 12.0.5


#54

我在出差,网访问 npm 很差,这几天感觉不太行


#55

@yuzhouheike @s2339956 npm publish 已更新


#56

大佬辛苦了


#57

感謝大佬 辛苦您哩!


#58

怎么能这么牛逼呢。。。粉


#59

折腾了半天,可以用了,想说,你咋这么牛逼呢


#60

get一下,说不定以后有用呢