LLVM混淆器Hikari


#222


张总,这个是我Xcode版本问题吗?


#223

试试安装Xcode Command Line Tools.
另外这个只识别标准路径的Xcode应该


#224

你好 我使用Hikari能够编译 运行成功项目,但是现在网络请求都是失败的,使用xcode自带的编译器运行则能正常请求,寻求下帮助。谢谢!


#225

这个描述跟没描述有区别吗。在原仓库按照模版开个Issue


#226

您好 ,请求网络问题已经解决了,现在真机运行商测试都没问题,打包的时候出现报错,还请求下帮助,谢谢!
报错截图如下:

Ld /Users/xiaomai/Library/Developer/Xcode/DerivedData/DJWapSDK-gqjypokrhgsmlkfuwsiviiwiqxyc/Build/Intermediates.noindex/ArchiveIntermediates/DJWapSDK/IntermediateBuildFilesPath/DJWapSDK.build/Release-iphoneos/DJWapSDK.build/Objects-normal/arm64/DJWapSDK normal arm64
cd /Users/xiaomai/Desktop/YYSDKDemo
export IPHONEOS_DEPLOYMENT_TARGET=8.0
export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
/Users/xiaomai/Library/Developer/Toolchains/Hikari.xctoolchain/usr/bin/clang -arch arm64 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.3.sdk -L/Users/xiaomai/Library/Developer/Xcode/DerivedData/DJWapSDK-gqjypokrhgsmlkfuwsiviiwiqxyc/Build/Intermediates.noindex/ArchiveIntermediates/DJWapSDK/BuildProductsPath/Release-iphoneos -L/Users/xiaomai/Desktop/YYSDKDemo/Libs/DJSDK/QFSource -L/Users/xiaomai/Desktop/YYSDKDemo/Libs/ThirdParty/Ipaynow3.0.3/iphone+simulator -L/Users/xiaomai/Desktop/YYSDKDemo/Libs/ThirdParty/Ipaynow3.0.3/iphone -L/Users/xiaomai/Desktop/YYSDKDemo/Libs/ThirdParty/SPaySDK1.2.4 -L/Users/xiaomai/Desktop/YYSDKDemo/Libs/ThirdParty/WechatSDK1.7.5 -F/Users/xiaomai/Library/Developer/Xcode/DerivedData/DJWapSDK-gqjypokrhgsmlkfuwsiviiwiqxyc/Build/Intermediates.noindex/ArchiveIntermediates/DJWapSDK/BuildProductsPath/Release-iphoneos -F/Users/xiaomai/Desktop/YYSDKDemo/Libs/ThirdParty/Alipay15.2.1 -filelist /Users/xiaomai/Library/Developer/Xcode/DerivedData/DJWapSDK-gqjypokrhgsmlkfuwsiviiwiqxyc/Build/Intermediates.noindex/ArchiveIntermediates/DJWapSDK/IntermediateBuildFilesPath/DJWapSDK.build/Release-iphoneos/DJWapSDK.build/Objects-normal/arm64/DJWapSDK.LinkFileList -Xlinker -rpath -Xlinker @executable_path/Frameworks -miphoneos-version-min=8.0 -dead_strip -Xlinker -object_path_lto -Xlinker /Users/xiaomai/Library/Developer/Xcode/DerivedData/DJWapSDK-gqjypokrhgsmlkfuwsiviiwiqxyc/Build/Intermediates.noindex/ArchiveIntermediates/DJWapSDK/IntermediateBuildFilesPath/DJWapSDK.build/Release-iphoneos/DJWapSDK.build/Objects-normal/arm64/DJWapSDK_lto.o -fembed-bitcode -Xlinker -bitcode_verify -Xlinker -bitcode_hide_symbols -Xlinker -bitcode_symbol_map -Xlinker /Users/xiaomai/Library/Developer/Xcode/DerivedData/DJWapSDK-gqjypokrhgsmlkfuwsiviiwiqxyc/Build/Intermediates.noindex/ArchiveIntermediates/DJWapSDK/BuildProductsPath/Release-iphoneos -Xlinker -final_output -Xlinker /Applications/DJWapSDK.app/DJWapSDK -fobjc-arc -fobjc-link-runtime -ObjC -lsqlite3 -lc++ -lWeChatSDK -lIPaynowPlugin -lz -lSPaySDK -framework SystemConfiguration -framework CoreTelephony -framework QuartzCore -framework CoreText -framework AlipaySDK -framework CoreGraphics -framework UIKit -framework Foundation -framework CFNetwork -framework CoreMotion -lIPaynowPlugin -framework AVFoundation -Xlinker -dependency_info -Xlinker /Users/xiaomai/Library/Developer/Xcode/DerivedData/DJWapSDK-gqjypokrhgsmlkfuwsiviiwiqxyc/Build/Intermediates.noindex/ArchiveIntermediates/DJWapSDK/IntermediateBuildFilesPath/DJWapSDK.build/Release-iphoneos/DJWapSDK.build/Objects-normal/arm64/DJWapSDK_dependency_info.dat -o /Users/xiaomai/Library/Developer/Xcode/DerivedData/DJWapSDK-gqjypokrhgsmlkfuwsiviiwiqxyc/Build/Intermediates.noindex/ArchiveIntermediates/DJWapSDK/IntermediateBuildFilesPath/DJWapSDK.build/Release-iphoneos/DJWapSDK.build/Objects-normal/arm64/DJWapSDK

ld: loaded libLTO doesn’t support -bitcode_hide_symbols: LLVM version 6.0.0 for architecture arm64
clang-6.0: error: linker command failed with exit code 1 (use -v to see invocation)
Command /Users/xiaomai/Library/Developer/Toolchains/Hikari.xctoolchain/usr/bin/clang failed with exit code 1


#227

文档里写了关闭bitcode


#228

谢谢 已成功搞定


#229

我配置完成以后Pod一直编译报错,开始提示缺少“ -bitcode_hide_symbols”,在我添加这个以后又出现了一个很奇怪的报错“clang-6.0: error: unsupported option ‘-b itcode_hide_symbols’ ”

求指教帮忙,谢谢


#230

您好,我的项目使用率Cocoapods,而且项目和pod的Build Setting 里面的Bitcode 全部设置成了NO,一编译就出现这个错误


我猜测需要在Cflag里添加“ bitcode_hide_symbols”,但是添加以后出现了这个奇怪的错误,希望张总能够帮忙解决,谢谢。


#231

说了关掉Bitcode。您关了吗


#232

我关闭了,您看



#233


关了是不会有这几个参数的


#234

没有的,原来就没加这些,然后我尝试着加了


再Archive(Release)的时候还是这样

Build(Debug)的话确是这个样子,一脸懵逼啊。。。

跪求帮忙解决[捂脸]


#235

再问个问题,这个Bitcode还有什么别的地方可以关么?


#236

PCH那个翻翻上面的回帖


#237


#238

那个我回你的时候就试过了,给你发截图的时候就已经加了


#239

index也关了?Pods跟主项目都要哦。扫二维码进群问吧


#240

超过100人,二维码不能加了。


#241

确实,同求入群